解决:Error: error:0308010C:digital envelope routines::unsupported

解决:Error: error:0308010C:digital envelope routines::unsupported

1、报错

启动vue项目,报错如下:

解决:Error: error:0308010C:digital envelope routines::unsupported

2、报错原因

出现这个错误是因为 node.js V17版本中最近发布的OpenSSL3.0, 而OpenSSL3.0对允许算法和密钥大小增加了严格的限制,可能会对生态系统造成一些影响.

在node.js V17以前一些可以正常运行的的应用程序,但是在 V17 版本可能会抛出这个异常。

3、解决方案

3.1版本降级,解决报错

尝试卸载Node.js 17+版本并重新安装Node.js 16+版本,然后再重新启动

这个方法,测试有效,但我推荐的是第二个办法。

3.2设置参数,解决报错

在执行运行项目命令之前,先运行这个命令:

Linux & Mac OS:

export NODE_OPTIONS=--openssl-legacy-provider 

windows命令提示符:

set NODE_OPTIONS=--openssl-legacy-provider 

这样就可以解决了,亲测有效。

唯一不足,是每次启动项目都要运行,所以,我们可以把它配置一下。也就是第三种方法。

3.3 修改配置文件,解决报错(推荐)

根据你的系统类型,选择一个上面的命令,如,我是Mac系统,我就用:

export NODE_OPTIONS=--openssl-legacy-provider 

然后,找到项目的package.json文件,把自己对应的命令,加上&&,写到启动项目的配置里面(构建写不写都可以),即可。

  • 例1:脚手架
"scripts": {
   "serve": "export NODE_OPTIONS=--openssl-legacy-provider && vue-cli-service serve",
   "build": "export NODE_OPTIONS=--openssl-legacy-provider && vue-cli-service build"
},

例2:Vue-Element-Admin

 "scripts": {
    "dev": "export NODE_OPTIONS=--openssl-legacy-provider && vue-cli-service serve",
//略...
  },

 

免责说明

本站资源部分来自网友投稿,如有侵犯你的权益请联系管理员或给邮箱发送邮件PubwinSoft@foxmail.com 我们会第一时间进行审核删除。
站内资源为网友个人学习或测试研究使用,未经原版权作者许可,禁止用于任何商业途径!请在下载24小时内删除!


如果遇到评论下载的文章,评论后刷新页面点击对应的蓝字按钮即可跳转到下载页面
本站资源少部分采用7z压缩,为防止有人压缩软件不支持7z格式,7z解压,建议下载7-zip,zip、rar解压,建议下载WinRAR

给TA打赏
共{{data.count}}人
人已打赏
人工智能实用工具建站教程微信源码

零基础5分钟搭建一个私有知识的AI机器人,接入微信、抖音和飞书

2023-9-15 8:44:14

建站教程

终极解决error:03000086:digital envelope routines::initialization error

2023-10-18 9:40:55

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
有新私信 私信列表
搜索